关于iis服务器的问题

(声明一下背景,本人用过apache+php+mysql的环境,会那么点前端)好了,事情是这样的,我买了个服务器,里面是win2008的,默认就安装好了个iis。现在我通过“添加网站”新建了一个网站,并且设置好物理路径并绑定了一个域名,但我把别人做好的程序(一个网站程序,需要asp+access支持)放进这个目录时,访问域名出现“您无权使用所提供的凭据查看此目录或页面。”,但我访问这个程序里的一个静态页面时(www.abc.com/helloword.html),却可以访问到,现在我要搞清几个问题,来排查究竟是环境问题,还是该程序问题,还是权限问题……因此我需要先了解这些:①iis是不是本身就是默认支持asp+access的?②别人给我的程序,是不是我放进根目录就能用?用不用像使用一些mysql支持的程序,需要设置数据库名,用户名,密码等等?③根据上面的提示“您无权使用所提供的凭据查看此目录或页面。”,是不是别人给我的程序我放进对应文件夹后,还需要设置访问权限?(但如果是访问权限问题,怎么解释我能访问里面的内页)我在——“应用程序池默认设置”——常规——“启用 32 位程序”设置为True后,页面访问变成了500:您查找的资源存在问题,因而无法显示。
2026年09月26日 14:06
有2个网友回答
网友(1):

1目前国内的主机商提供的iis服务器一般都会帮你安装相关的服务器组件,以支持asp、php、mysql、sql server等,
2access数据库一般也不需要设置用户名和密码,只需要有设置文件(Conn.asp文件)中设置数据库路径,但我认为不是这个原因。
3.造成这种出错是的原因可能很多,大多数都是权限问题,你右单击iis中左侧的网站,选择属性,切换到目录安全性,看看这里面的设置有没有问题?尤其是匿名使用帐户那里!另外查看主目录选项卡下,“执行权限”那里是否已启用“脚本”。打开windows的帐户用户,看看匿名帐户有没有启用,或者有没有足够的权限。

应用程序池默认设置500有点小了,那里指的默认连接数,表示超过500后iis会自动收回资源!win2008的iis我不是很了解,汗!我用的都是古老的win2003,所以有些设置可能不大一样

网友(2):

  1. iis支持asp+access,使用access数据库你网站目录需要网站用户的读写权限。

  2. 你做好程序,你放到你创建好的网站去就行了,如果程序设置时候是使用mysql数据库才需要安装mysql,access也是一种数据库。

  3. 这个应该是你网站没创建好,网站用户权限没设置对

  4. 你设置启用32程序池,这个没什么问题,如果是64位系统,你iis需要降位或你那样设置下,不然网站可能会报错,报500错,你服务器asp功能里要设置吧错误发动到浏览器,然后服务器上的ie的internet选项高级里的 http友好前面的勾选要去掉,然后再到你服务器上去访问,就可以看到报错了,500错不是真实报错