VPS里配置IIS的时候遇到关于端口的问题

刚买的VPS,不太会用。买的时候里面IIS PHP MYSQL 等都是配置好的。IIS里有两个网站,第一个是默认网站,是80端口。一个是PHPmyadmin,是8090端口。然后直接打开VPS的独立IP后面跟这两个端口,都可以直接访问相应的网站现在问题是我新建一个网站,端口改成8080 或者88,或者其他的端口,直接用IP地址后面加上端口,无法访问。我以为是我新建的时候配置错了,后来把phpmyadmin的停止了,新建一个网站,端口改为8090就可以正常访问,看来是端口的问题了?求解答,感谢!
2026年09月28日 11:02
有5个网友回答
网友(1):

网站的端口默认都是80的,不要用其他端口,否则域名解析过去还是访问不了。注意看下域名是否不是正确绑定到IIS的网站属性里面了。正确绑定,并使用80端口,肯定是可以打开的。

网友(2):

你要用一个IP多个端口搭建多个网站的话,你的方法是对的,但前提是防火墙对应的端口有没有例外开放(你有没有开防火墙)以及IIS构造是否正确(之前无法访问的网页提示什么错误)。
例如我的IP是199.1.1.1,如果我不绑域名的情况下,直接想通过端口访问我的网站,端口可以随意设定,这需要怎么做? IIS里好像如果用同样端口的话,就只有一个可以启
针对这个,你若是一个IP的话,那么一个网站就占一个端口,不然无法访问
你若是几个IP对应几个网站的话,完全可以一个IP一个网站都用80端口的

网友(3):

iis5.1默认的是开的80端口,而目前,网通电信都把80端口屏蔽了(不让个人建站)试试开其他端口,并且在路由里映射该端口 测试的时候可以试试telnet 你的ip地址 :端口号必须在外网测试,通的话就能访问了。再者就是项目的权限,给个user权限基本就行了,或者直接给everyone权限 ~

网友(4):

查看防火墙是否防火墙屏蔽了其他端口。
很多时候是因为防火墙导致的诸如此类问题!

网友(5):

你的IIS里开启了端口了吗