如何解决wordpress4.1

2026年09月26日 18:01
有2个网友回答
网友(1):

  wordpress升级失败什么原因?如何解决?下面是wordpress升级失败的原因及解决方法分享。

  1、网络问题

  现象:点击更新提示,浏览器右下角一直提示连接域名,然后没有然后了。

  原因:wordpress的服务器在国外,国内主机去访问,速度有时候不稳定。

  处理方案:建议换个时间去更新,实在不行直接选择手动升级。

  2、文件权限问题

  现象:点击更新提示,要求输入FTP账号、密码什么的,linux主机较多出现。

  原因:出现这个提示,一般是指文件夹没有写入权限;网站程序更换系统环境时,好比从A主机到B主机,文件夹权限可能没有正确传递,很容易出现这种情况。

  处理方案:可以直接输入FTP账号、密码;部分VPS或云主机,没有开通过FTP,可以赋予网站目录www用户权限,命令是chown -R www /home/web/wordpress;当然,还可以用winscp等工具登陆ssh,直接鼠标右键修改文件夹权限。

  3、环境配置问题

  现象:点击更新提示,看起来在正常更新,过会儿停留在空白页面。

  原因:出现这个提示,原因有很多,好比开启了防目录跨站功能。

  处理方案:如果是虚拟主机,联系空间商处理;如果是VPS或云主机,可以去主机控制面板或防火墙软件上,暂时取消掉类似的安全设置。

  至于怎么取消,要看具体情况,一般是设置php.ini文件,搜索open_basedir,在前面加上#注释掉;部分防火墙软件,也有可能有类似的功能,限制了网站程序目录权限。当然,为了安全,不建议取消防跨站功能,可以通过手动升级来替代。

  除开上面几种常见的情况,有时候可能会遇见更奇怪的情况;这个时候,不妨手动升级程序,只要简单五步,即可顺利升级到最新版的wordpress程序。

  手动升级wordpress

  1、登陆网站**,暂停正在使用的插件,备份数据库及网站;

  2、到wordpress官网下载最新的程序,压缩上传到网站根目录;

  3、解压覆盖网站目录下的wp-admin、wp-includes文件夹;

  4、解压覆盖根目录下面的其它文件(wp-config.php除外);

  5、访问http://域名/wp-admin/upgrade.php升级,按提示操作。

  注意事项:注意备份网站和数据库,替换过程中,保留wp-content目录(主题目录,非常重要)、wp-config.php(数据库配置文件,非常重要)、robots.txt(一般重要)、favicon.ico(一般重要)等文件。按这个流程操作,99%可以正常升级;若依然升级失败,可能是数据库或其它配置坏了,建议先默哀,再查找原因。

网友(2):

说白了就是服务器的承受能力。

第一,确认服务器硬件是否足够支持当前的流量。
普通的P4服务器一般最多能支持每天10万独立IP,如果访问量比这个还要大,那么必须首先配置一台更高性能的专用服务器才能解决问题,否则怎么优化都不可能彻底解决性能问题。

第二,优化数据库访问。
服务器的负载过大,一个重要的原因是CPU负荷过大,降低服务器CPU的负荷,才能够有效打破瓶颈。而使用静态页面可以使得CPU的负荷最小化。前台实现完全的静态化当然最好,可以完全不用访问数据库,不过对于频繁更新的网站,静态化往往不能满足某些功能。
缓存技术就是另一个解决方案,就是将动态数据存储到缓存文件中,动态网页直接调用这些文件,而不必再访问数据库,WordPress和Z-Blog都大量使用这种缓存技术。我自己也写过一个Z-Blog的计数器插件,也是基于这样的原理。
如果确实无法避免对数据库的访问,那么可以尝试优化数据库的查询SQL.避免使用Select *from这样的语句,每次查询只返回自己需要的结果,避免短时间内的大量SQL查询。

第三,禁止外部的盗链。
外部网站的图片或者文件盗链往往会带来大量的负载压力,因此应该严格限制外部对于自身的图片或者文件盗链,好在目前可以简单地通过refer来控制盗链,Apache自己就可以通过配置来禁止盗链,IIS也有一些第三方的ISAPI可以实现同样的功能。当然,伪造refer也可以通过代码来实现盗链,不过目前蓄意伪造refer盗链的还不多,可以先不去考虑,或者使用非技术手段来解决,比如在图片上增加水印。

第四,控制大文件的下载。
大文件的下载会占用很大的流量,并且对于非SCSI硬盘来说,大量文件下载会消耗CPU,使得网站响应能力下降。因此,尽量不要提供超过2M的大文件下载,如果需要提供,建议将大文件放在另外一台服务器上。目前有不少免费的Web2.0网站提供图片分享和文件分享功能,因此可以尽量将图片和文件上传到这些分享网站。